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BASICS OF SAMPLE CHOICE/PREPARATION FOR CT
SCANNING

Size, Shape, and Resolution

e Samples will be mounted onto a turntable on which they will rotate in between an X-
ray source and X-ray detectors. Consequently, the imaged area is cylindrical and the
optimal shape for the scanned sample is cylindrical. Samples are often mounted for
scanning in a cylindrical container.

e At UTCT we have three scanners:

e Our high-energy subsystem (NSI — GE Titan 450 kV) can accommodate a sample
up to 40 cm in diameter and 75 cm in height. Scanning can be done using either a
conventional ‘volume’ scanning routine, or using a helical scanning protocol for
objects having a high aspect ratio. Scanning large objects requires sufficient X-ray
energy to adequately penetrate the sample.

e Our high-resolution subsystem (NSI — Feinfocus 225kV) can accommodate
similarly-sized samples as the high-energy subsystem, but employs a microfocal
X-ray source, capturing higher resolution images for specimens that can be
adequately penetrated by the lower-energy X-ray source.

e Our Xradia scanner (microXCT 400) has a maximum field of view of ~5 cm,
although it can accommodate slightly larger samples for subvolume scanning if
the sample is not composed of a highly attenuating material.

¢ In general, the maximum axis of the sample determines the scan resolution, although
this is somewhat dependent upon the density of the sample. The maximum in-plane
resolution for all UTCT scanners equals about 1/2000 of the sample maximum axis
(e.g., a 40 mm sample will have a resolution of about 0.02 mm). The resolution of our
high-energy subsystem is also limited by the larger X-ray focal-spot size of the GE
Titan X-ray source, which is either 0.4 mm or 1.0 mm depending on the scanning
mode.

e X-rays are attenuated as they pass through materials, leading to a number of scanning
artifacts (principally ‘beam-hardening’ artifacts, whereby the edges of the specimen
appear artificially bright). Accordingly, if dealing with a rock or fossil, it is best to
reduce the amount of material through which the X-rays will have to pass to image the
area of interest. In other words, the more matrix removed from a fossil specimen prior
to scanning, the better the data will be. If scanning a fossil on a slab, trim it as close to
the specimen as possible before scanning. With Recent specimens, remove any
metallic tags or pins, as these will cast artifacts. Also check that the specimens were
not collected with a shotgun!

To summarize, when possible choose samples that best approximate a cylindrical
geometry, and that will fit onto an appropriate scanner. A cylindrical geometry is
naturally best, but if this is not possible then the more equant the sample is in the scan
plane, the better. Remove as much matrix as possible from a fossil specimen and consider
the maximum dimensions of the scanner if choosing from a series of specimens to scan.



For pickled specimens consider the relationship between geometry and resolution and
choose specimens in which the extremities are fixed in a position close to the body rather
than extended.

Consider the resolution that your study will require. In principle you will need to have at
least three voxels (3D pixels) spanning the structure of interest in order to measure it.
For example, if you wish to measure a structure that is 0.075 mm in diameter, you will
need to have a scan resolution of at least 0.025 mm, and the maximum diameter of the
sample must consequently be less than 25 mm (or 50 mm in the case of the Xradia
scanner).

Sample Mounting

It is imperative that specimens do not shift or move during the scanning process; this
includes thawing in frozen specimens, and drying in pickled specimens. Specimens are
fixed into a rigid position using a variety of materials, such as florist foam, sheets of
polyethylene foam, and plastic cylinders.

e Samples are mounted to fit into the cylindrical scanning geometry, and great care is
taken to make sure that the entire region of interest fits within the X-ray beam. If the
specimen, or parts of the specimen, falls outside the X-ray beam it will cause artifacts
that typically manifest at the edge of the scan field. Occasionally we intentionally
allow some of the specimen to fall outside the X-ray beam so that we can ‘focus in’ on
a region within the specimen (e.g., the skull in an articulated fossil). In such cases, we
typically reconstruct the scans to a smaller field of view to crop out the affected
regions at the edge of the scan field.

e We often use florist foam, which is low-density and thus relatively transparent to X-
rays, to fix or wedge specimens into their desired mounted positions. Florist foam is
rigid and easily carved into customized shapes, making it ideal for fashioning ‘cradles’
for mounting fragile fossils or recent specimens that require substantial support.

e Oddly-shaped specimens or objects that require stabilization (i.e., with irregular
bottoms or possibly moving parts) are typically mounted into plastic cylinders for
scanning. This allows us to center the specimen and articulate it into its desired
scanning configuration with florist foam or polyethylene foam sheets. High-aspect-
ratio specimens, such as lizards, snakes, and some fish, can be quite difficult to mount;
we often only want to scan the head, and there may be a lot of body attached to it.
Typically we will mount them into a cylinder after ‘sausaging’ them with sheets of
polyethylene foam or alcohol-soaked cheese-cloth to fix them into position. For small
snakes and squamates with reduced limbs, we will often ‘cinch’ the specimen in a
large diameter straw that we have slit lengthwise (McDonald’s super-size fatty
McFatFat straws work especially well).

e Pickled specimens are typically mounted into plastic cylinders that can be sealed for
scanning. This allows us to center the specimen, and align it into its desired scanning
configuration with florist foam or polyethylene foam sheets. For scans that take more
than a few hours, we will often swaddle the specimen in alcohol-soaked cheese-cloth
to make sure that it does not dry out (and thus move) during the scan.



For samples to be scanned on the Xradia scanner, centering is not as critical because
that stage can be centered on all three orthogonal axes. However, immobilizing the
sample is of greater concern because at higher resolutions (and thus longer scan
durations) there is less tolerance for sample movement.

When recent specimens have been preserved in alcohol it is generally difficult or
impossible to digitally reconstruct the exterior of the animal (i.e., the skin). The
alcohol has similar properties to soft tissue as imaged by the X-rays, and is generally
indistinguishable from skin and other soft tissue. The alcohol gets sucked up by
capillary action into the foam or cheese-cloth surrounding the specimen and obscures
the boundary between specimen and mount in the data.

Frozen specimens should be thawed prior to scanning, as they tend to shift when
thawing. If you will be using a super-fast scanner and are confident that the sample
will not thaw, then you could try to leave them frozen for scanning.

For Recent skulls and mandibles, it may be desirable to put some sort of divider
between the upper and lower teeth (e.g., florist foam). This will make the mandibles
easier to digitally isolate later, if desired. Similarly, it can be helpful to put some sort
of separator in the jaw joint. Beeswax works well, as it also helps to fix the mandible
in place and is easily and cleanly removed post-scan.

Finally, although specimens can be resliced digitally in any direction, it is always best
that the original data be as ‘orthogonal’ as possible. This may require quite a bit of
fussing when selecting and mounting the specimen, but allows easier interpretation of
the scan data without secondary processing. As always, a little care and attention up
front can save hours of work later on.



PROGRAMS USED/AVAILABLE FOR IMAGE PROCESSING

Freeware

e IrfanView: viewing serial slice sequences, renaming and resizing files, and converting
file formats

e Www.irfanview.com

e Imagel: image processing (e.g., cropping, adjusting levels, reslicing data, adding slice
numbers) and measuring, can be used for image stacks

e imagej.nih.gov/ij

e 3DSlicer: 3D visualization and measurement program (for those who do not want to
buy a 3D visualization program)

e slicer.org

Commercial 3D Visualization & Measurement Software

e Auvizo (formerly Amira): less expensive than VGStudioMax, excellent for measuring,
segmenting and making surface models

e Www.vsg3d.com/avizo/overview

e VGStudioMax: not inexpensive, excellent for making volumetric renderings,
segmenting and making surface models

e www.volumegraphics.com/en/products/vgstudio-max.html

Animations
e QuickTime Pro

e www.apple.com/quicktime/download/



PROCESSING WITH Image]

Resizing and Cropping Dataset

You will often need to reduce the size of a dataset to work with it in 3D rendering
programs. This is especially true if you plan to do any particularly memory-intensive
activities like segmentation. Simple ways to do this are to downsample the data from 16-
bit to 8-bit TIFFs (reduces file size by 50%), downsize the dimensions of the slices (e.g.,
from 1024 x 1024 pixels to 512 x 512 pixels; reduces file size by 75%), and/or crop the
slices.

Another reason to convert from 16-bit to 8-bit is that many programs cannot handle 16-
bit data, or offer limited options for processing them (e.g., Photoshop, Irfanview). For
example, Photoshop reads in 16-bit data as 15-bit data (although all documentation refers
to it as 16-bit), resulting in a small amount of data loss that may affect some users (e.g.,
those using the data in numerical analysis programs or simulations). Therefore, we
strongly recommend doing 16-to-8-bit conversions using ImagelJ, Avizo, or
VGStudioMax.

e Load 16-bit image sequence into Imagel: File=> Import-=>Image Sequence; navigate
to 16-bit folder and double click on 1% slice; select OK in Sequence Options window.

e |f ImageJ prompts that you do not have enough memory to open the stack, then
you will need to change the amount of memory allocated to ImageJ: Edit
2>Options>Memory & Threads...; increase Maximum memory to a larger
value (corresponding to your computer’s capacity). Close and reopen program.

e To downsample the data, go to Image->Type and select 8-bit. ImageJ will convert
the open images to 8-bit. Note that this operation optimizes the grayscales to whatever
is displayed in the viewer. If you wish to maximize the range of grayscale values when
converting from 16-bit to 8-bit, then the entire volume needs to be set to the maximum
16-bit range prior to down-sampling to 8-bit: Image>Adjust>
Brightness/Contrast; in the window that pops up, click Set, and adjust the Minimum
and Maximum displayed value to 0 and 65535 respectively (which corresponds to a
16-bit maximum grayscale value range from 0 to 65535).

e To resize the data, select Image-> Adjust->Size; set new width and height as desired
(e.g., 512 pixels), select OK. It is advantageous to pick a size that is a multiple scalar
of the original dimensions as this will require no interpolation of the data.

e To crop the data, select a crop area by clicking-and-dragging the mouse on an image
in the stack. Check each side of cropping bounding box with the slider through the
entire image sequence to make sure specimen is not clipped; Image-> Crop.

e After downsampling, resizing or cropping the data, select File>Save As—=>Image
Sequence; make a new folder into which the image sequence is saved.

e *A note of caution: cropping images does not change in-plane resolution, but resizing
does.



Orthogonally Reslicing Data

CT data can be orthogonally resliced with ImageJ:

Image—>Stacks—=>Reslice [/]; in the pop-up window, choose the side of the stack from
which you wish to reslice (e.g., Top, Left, Bottom, Right) and click OK. ImageJ will
indicate the direction of reslicing as it processes the data, and will generate a resliced
stack. File>Save As->Image Sequence; make a new folder and save the resliced
data.

Note that ImageJ exports the reslicings with a voxel aspect ratio of 1:1:1, so the YZ
reslicings will look ‘squatty’ and the XZ reslicings will look ‘stretched’ if the Z
(interslice) spacing differs from the X and Y (interpixel) spacing (either because the
original voxels were not equant, or because the data have been resized). In such cases, the
reslicings require stretching to their appropriate aspect ratio. To do this:

e Calculate the voxel aspect ratio: interslice spacing/(field of reconstruction/image
resolution).

e Multiply voxel aspect ratio by the number of slices in the original data; this gives
you the correct length, in pixels, for your reslicings; round to the nearest pixel.

e In ImageJ, open one of your reslicings if it is not already open, then Image—>
Scale; in the pop-up window, adjust the Width (pixels) or Height (pixels) to the
appropriate length as calculated above.

e File->Save As>Image Sequence.

Adding Slice Numbers

File-> Import->Image Sequence; browse to and load slices.

Image->Stacks—>Label; Starting Value is 1, Interval is 1, X Location is 5 (pixels
from left margin), Y Location is 18 (pixels from top margin), Font Size is 14, and
Text is blank. Click OK. These are the values that we use for standard DigiMorph.org
processing. Feel free to change the location of the labels as desired.

If you cannot see the slice numbers, the text is likely black (ImageJ’s default). Change
the text color to white by going to Edit->Options—=>Colors and selecting white as the
foreground color. Then repeat the step above to add the label.

File->Save As—>Image Sequence.

Other Useful Features: Orthogonal Views, Histogram, Transform
Data, Measure, etc.

Orthogonal views: Image->Stacks>Orthogonal Views. This option presents a
dynamic reslicing of the original CT stack. The “cross-hairs’ can be dragged with the
mouse to locate features in the different planes. Note that, as with the resliced data, the
orthogonal views assume equant voxels, and the reslicings will look stretched or
squatty if the voxels are not isometric.



e Histogram: Analyze->Histogram. Allows you to look at a histogram of the grayscale
values in one slice, the whole volume, or some region of interest (as defined with the
selection tools). This is an easy way to quantify the distribution of grayscale values in
your data.

e Adjust brightness and contrast: Image->Adjust->Brightness/Contrast; if you are
planning on changing the contrast or grayscale levels of your data, we recommend
adjusting the brightness and contrast on the 16-bit data prior to downsizing to 8-bit —
this will retain far more data than adjusting after converting to 8-bit data. Keep in
mind that ImageJ uses the adjusted window levels of the 16-bit data as the grayscale
range for the down-sized 8-bit data (see above discussion). Unfortunately, you cannot
apply adjusted grayscale levels to 16-bit data in ImageJ.

e Measuring: Analyze->Measure. Will measure lengths, areas, grayscale values
(including standard deviation; mean, min and max values), angles, coordinates of
points, and a variety of other values, depending on the chosen selection tool.

e Line profile plots: Analyze->Plot Profile. Will plot the grayscale profile of a line or
rectangle.

e Binning data: Image-> Transform->Bin... Will shrink the data in X, Y, and Z.

e Transform data: Image->Transform; allows rapid reorientation and downsizing of
the data (i.e., flipping, rotating, translating, binning, etc.).

ImageJ offers many other useful features, and the above list is far from comprehensive —
we encourage you to explore this powerful software on your own. Because ImageJ is
open-source, there are also many useful plugins that can be downloaded from third-party
webpages — some these are linked from the ImageJ website, and a version of ImageJ
called Fiji (Fiji Is Just ImageJ) is available that includes most of the available ImageJ
Plugins

Among the plugins included with an ImageJ standard download are several that can be
used for volume rendering or generating surfaces with tomographic data. Although these
3D Plugins are slow, and seem to choke on large data sets, they may provide a useful free
alternative for generating static images if Avizo or other 3D packages are not available.



AVIZO

Avizo is a 3D volume viewer that has excellent segmentation, isosurfacing, and basic
measurement capabilities. It also has a volume rendering engine, although we feel that
the more expensive VGStudioMax surpasses Avizo in this regard because of its superior
lighting and shadow casting. This short course will use a CT dataset of the skull of
Crocodylus moreletti to showcase 2D and 3D data visualization, segmentation (i.e.,
digital dissection), and linear and volumetric measuring in Avizo.

Loading Data into Avizo

e Open Avizo 8.0; File>Open Data, or select green Open Data icon from the Main
Panel window at top-right of screen.

e Navigate to the appropriate folder, highlight all slices (Ctrl-A) and select Open. If a
warning message appears, select ‘Read complete volume into memory (slow),” then
OK.

e Fill-in voxel size (voxel = three-dimensional pixel) in Image Read Parameters
window. Use the contents.docx file associated with the dataset to determine voxel size.
The voxels in the provided resampled Crocodylus data equal 0.381mm in X, Y, and Z.

e Note that if you have resized the data before loading, then you will have to adjust
the voxel size accordingly. For example, if you have reduced the data from a 1024
x 1024 image size to a 512 x 512 image size, then the X and Y spacing, but not
the Z spacing, will be twice as large.

e Also note that datasets can be acquired with different spacing in Z (interslice
spacing) relative to X and Y (interpixel spacing). Generally the contents.docx file
accompanying the data will specify the interslice spacing, but the X and Y
spacing is calculated by dividing the field of reconstruction (in mm) by the image
size (in pixels).

e Click OK and a green icon will appear in the Main Panel window
[ A

e SAVE your Avizo project: File->Save Project.

The Avizo Layout
e Viewer: the largest window, displays dataset renderings.

e Main Panel: located to the upper-right of the Viewer. This window contains the
Project View that displays icons (modules) representing the original dataset as a
whole, together with other icons that represent modifications that are made to the
dataset. The actions and icons that are applied to the data are attached with lines that
indicate their relationships. Multiple datasets can be loaded at a time. You can switch
between datasets and attachments by clicking the different icons. The icons themselves
generally have a small white square on their left margin from which the attachments



between icons are specified. Clicking the small orange square just to the right of the
white square will control the object’s visibility in the Viewer.

e Properties: located directly beneath the Main Panel. This window displays the
various options/settings that can be applied to an object in the Main Panel. When an
icon is selected in the Main Panel, its properties are displayed in the Properties
window. This is where you can edit/modify various settings for a particular function of
your dataset. In most Properties windows, a “?” button located in the upper right-hand
corner will activate an online manual that lists options available for the selected
module.

e Console: located directly beneath the Viewer. The Console window prints updates as
data are read, saved and analyzed. It can also be used to type in commands for various
functions in Avizo. A list of commands can usually be found in the Help section for a
particular module. The Console is disabled by default; to unhide it, go to
Window->Console.
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Note: the above image illustrates the Avizo windows after a data set has been loaded, and
an orthosclice displayed.

Getting Started: Navigation and Interface of Avizo
Click on the green data icon to select it, and look at the Properties for the data. This

includes information on the dimensions of the data set, data type, and voxel size. Make
sure that the voxel sizes are correct.
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Elf the voxel sizes are not correct you can edit them using the crop editor tool at the
upper right of the Properties window.

Right-click on your green data icon in the Main Panel, select Display-=>Ortho
Slice-> Create; this gives you a view of a slice from your dataset in the Viewer window.
The slices you imported are in the xy orientation in Avizo, corresponding to a transverse
or coronal orientation in the Crocodylus data.

The Viewer window menu bar of Avizo presents options for interactively working with
the data using your mouse in the Viewer window. The default color of the Viewer
background is a gradational gray; this can be changed by selecting View->Background.
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Viewer Interaction Buttons

. E} The Arrow or ‘Interact’ tool allows the user to perform different operations on
the data volume, such as scrolling through the stack, adding measuring lines or adding
clipping planes.

o &E‘. The Hand or ‘Trackball’ tool changes the viewing direction of the camera within
the Viewer. The default mode rotates the camera in any direction. Holding down
either the “Ctrl’ or *Shift’ key while using this tool limits the rotation to a single
orthogonal axis. Later you will see how this tool will allow you to manually change
the orientation of the rendered dataset, useful for objects that may have been scanned
non-orthogonally.

° @ The Crossed Arrows or ‘Translate’ tool translates the camera within the Viewer.
° i‘{} The ‘Zoom’ tool zooms the camera in and out on the volume.

o @ The ‘Rotate’ tool rotates the camera one degree clockwise each time it is
pressed; rotation will be counter-clockwise if the ‘Ctrl’ key is held down as well.
Pressing the ‘Rotate’ button while holding down the *Shift’ key rotates the camera 90
degrees.

. % The “Seek’ tool zooms in on any area indicated by a mouse click.

) D The ‘Home’ tool returns the Viewer to its original state and the camera to its
original position. Selecting the ‘Set Home’ button next to it resets 'Home' to whatever
is currently displayed in the Viewer.

o ﬁ: The “Perspective’ tool sets the camera for the Viewer to either perspective or
orthogonal. Generally you will want this set to orthogonal (i.e., parallel lines in front
of eye) because perspective distortion complicates taking measurements.

View Buttons

o @"'@“@“@ These hexagonal-shaped ‘Planar’ icons allow you to view data at

different planar orientations orthogonal to the scanning axis.

Stereo/Measuring/Snapshot Buttons

(s

. The *Stereo’ button allows you to enable/disable stereo viewing.
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. The ‘Measure’ tool is a shortcut for the measuring option in the Main Panel
window (see section on Measuring below).

o The “Snapshot’ icon allows you to capture an image of the data as displayed in
the Viewer.

Layout Buttons

M3 &8 B

o These layout icons allow you to display the Viewer in
different formats. From left to right they are Layout (one view displayed in Viewer),
Layout 2V (Viewer split vertically to display 2 views at once), Layout 2H (Viewer
split horizontally), Layout 4 (Viewer split into 4 views), and Fullscreen (Viewer fills
the entire monitor screen; right click to exit).

AR

- ’I_.-l'

o I l'u"' ~ Finally, in the lower right-hand corner of the Viewer is a rotational sphere
called the ‘camera trackball’ that is only visible when scrolled over. Whereas the
‘Hand’ (Trackball) button allows you to freely change the viewing direction of the
camera, the ‘camera trackball’ is used for constrained rotation of the camera about the
screen-aligned X, Y, or Z axes. This tool allows you to virtually “walk-around” the
volume as displayed in the Viewer. This feature is disabled by default; to enable,
right-click in the Viewer window and select ‘Show trackball.” The “View’ buttons can
be used to easily reset your view after using the trackball.

Working with Ortho Slices
Delete all icons in the Main Panel except for your green data icon.

e Right-click on the green data icon and select Display->Ortho Slice>Create (or
select the ‘OrthoSlice’ button at the top of the Project View tab of the Main Panel
window); an orange Ortho Slice icon appears, attached to your green data icon by a
line, and different options appear below in the Properties window.

e In the Properties window select an Orientation: xy (imported slice orientation;
coronal or transverse in Crocodylus), xz (frontal or horizontal), or yz (sagittal).
Navigate through the slices in this orientation by using the triangular slider in the Slice
Number field or by selecting the ‘Arrow’ button and dragging the mouse upwards and
downwards through the slices. If scrolling with the mouse does not work, rotate the
orthoslice slightly in the Viewer or switch to perspective view before scrolling.

e The Frame option allows you to turn the orange frame around the orthoslice on or off,
and also to adjust its width and color (by clicking the color tab).

e Under Options: “‘Adjust view’ automatically adjusts the Viewer to display whichever
orientation is selected; “bilinear view’ interpolates the data to render a smoother (and
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blurrier) dataset; and ‘lighting’ simulates the slice being illuminated by a head light,
with more oblique views of the slice being darker.

The Mapping Type allows you to select between two mapping methods, either a
Colormap or Histogram equalization. The default setting is Colormap, which allows
the maximum and minimum values of the grayscales in the slices to be adjusted by
sliders, or by typing in values (zero corresponds to pure black, and 255 corresponds to
pure white (8-bit data), using a minimum value greater than zero will make the air in
your slices appear black). The “edit” button allows application of a different colormap,
as well as other options for modifying the colormap. Selecting the Histogram setting
allows a contrast limit to be applied — the higher the value, the greater the contrast.

The Slice Number slider allows you select different slices in the Viewer.

Transparency determines the transparency of the slice. None means that the slices are
fully opaque; binary allows you to eliminate the background by making black
grayscale values (lower than the min value you enter) transparent; alpha makes
transparency proportional to whiteness.

Right-click on the green data icon and select Display-=>OrthoSlice=>Create two more
times. Left-click on each new Ortho Slice and select the remaining orientations for
each. There should now be three different orthoslices in the Viewer, allowing you to
view the three orthogonal slice planes simultaneously. You can rename each Ortho
Slice module to help keep them straight (click on the Ortho Slice icon in the Main
Panel and press the ‘F2’ key to enable renaming).

Use the “Hand’ (Trackball) tool to rotate your image, as you navigate through the slices
using the Slice Number slider in the Properties window. This will give you a feel for the
size and other characteristics of your dataset.

Clicking the orange box within each Ortho Slice icon in the Main Panel turns those
slices on and off. To change the view directly to an orthogonal plane, select the desired
Ortho Slice, and then click on the appropriate planar icon from the top margin of the
Viewer.

Working with Oblique Slices

To generate an oblique slice, right-click on the green data icon in the Main Panel and
select Display->Slice->Create; the Properties dialog is similar to that for Ortho Slice:

e Options:

e Adjust: resets the camera each time a new slice orientation is selected.

e Rotate: moves slice to an oblique position. A large sphere, or rotating ball, will
appear centered on the slice. Using the *Arrow’ (Interact) button, select anywhere
on the sphere except the handles to rotate it freely. You can rotate in just one
plane by clicking on one of the handles on the sphere.

e Immediate: simultaneously renders new slice planes as you toggle through them.
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Fit to points: allows you to define an oblique slice plane by selecting three points
on the slices (by clicking with the “Interact’ tool on the slices in the Viewer).

Translate: allows you to scroll through the oblique orientation of the object,
similar to the *Slice Number’ in Ortho Slice.

Mapping type: acts as in Ortho Slice.

Sampling: allows you to adjust the reconstruction quality of the data. We
recommend setting to ‘finest’ (finest corresponds to the size of the original
dataset) and selecting both the “interpolate data’ and ‘interpolate texture’ options.

Filters: This allows you to apply a filter to the slice, up to a value of five. Note
that some filters will greatly increase rendering time of the slice. Play around
with applying different filters. Decreasing the mapped data maximum (Data
Window property) will allow your changes to be seen more easily.

Isosurfaces and STL Files

An isosurface is a 3D analog of an isocontour that is rendered as a mesh of polygons. The
‘contour’ corresponds to a grayscale threshold value. Individual voxels are not rendered,
and if you cut into the isosurface there is nothing inside.

e Delete all icons in your Main Panel except for your data icon.

e Right-click on green data icon and select Display->Isosurface->Create; a yellow

Isosurface icon appears in the Main Panel.

¢ In Properties under Options check ‘downsample’ (to speed rendering).

e Experiment with the Threshold parameter (be sure to click Apply to render the

isosurface). The threshold value will be a grayscale value between 0 and 255 (for 8-bit
data, or 0 and 65535 for 16-bit data); this will generate a surface around all voxels
with grayscale values greater than the threshold value.

e To see the distribution of grayscales represented by the voxels in your dataset,

right-click on the green data icon and select Measure And Analyze->
Histogram—->Create; a yellow Histogram icon appears in the Main Panel.

In Properties, change the number of bins (Max Num Bins) to 256 and click
Apply. A Histogram-Plot window appears; double-click on the X-axis and a
Histogram-Plot-ObjectEditor window appears.

In the Histogram-Plot-ObjectEditor, select ‘axis’ in the list on the left hand side
of the window, and for the X axis tab under Range unclick Auto and change to O-
255 (for 8-bit data); for the Y axis, verify that the Type is ‘Log’. Click OK to exit
the dialog.

Choose a threshold value that does not create artificial holes in the skull (value too
high) but also does not make the skull look bloated (value too low). In the Properties
window for the isosurface, place the slider somewhere in the middle to start, and select
‘Apply.” Avizo will generate an isosurface of your dataset. Then experiment with
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lower and higher values (hint: somewhere in the realm of 65-70 is a good threshold for
Crocodylus). Note that, although the theoretical threshold value should correspond to a
gray value that is halfway between the average value of the two materials (i.e., bone
and air in this case), the actual threshold value may need to be adjusted to visualize
features that are near the scans resolution (i.e., very thin features), or when there are
more than one component being thresholded together (e.g., bone and enamel in this
case).

e Double-click the colored rectangle in the Colormap parameter to view a Color
Dialog. Select a color, and opacity if you wish a semitransparent surface, and click
‘Apply.” Close Color Dialog.

You can also render an isosurface using the graphics card (and not the CPU) by right-
clicking on the data icon and then Display->Isosurface Rendering—> Create. This will
render an isosurface (after you have chosen a threshold as above). This isosurface cannot
be used to generate STL files, however, but can be used for viewing onscreen or for
generating animations.
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To make an STL file from an isosurface (which can be used to 3D print the isosurface or
to view it in CAD programs or VRML):

e Select the Isosurface icon (not the Isosurface Rendering icon) in the Main Panel. In
Properties, under Draw Style select More Options—>Create Surface; this will
generate a green .surf object in the Main Panel.

e Turn off the Isosurface in the Main Panel; right-click on the .surf object and select
Display—>Surface View-> Create to display the surface.

e To decimate the surface file (i.e., reduce the number of polygons in the file to decrease

file size), select the .surf object, and in Properties select the % ‘Simplifier” button.
Properties will display how many faces are currently in the surface model (at the top
listed after Surface). You can usually throw out at least half of the faces (= 50%
decimation = a 50% smaller STL file) with little effect on the appearance of the
surface. Enter the desired number of faces under Simplify then click Simplify Now.

e To smooth the surface, right-click again on the green .surf object, and select Surface
Transforms—>Smooth Surface->Create; we recommend up to 4 iterations with
lambda 0.9. Pressing Apply creates a green .smooth object in the Main Panel; right
click on it and select Display->Surface View—>Create to see the surface file.
Compare it to the un-smoothed version by clicking its orange box on and off.

e To save the smoothed surface select the .smooth object then go to File->Save Data As
in the main Avizo window and save as ‘STL binary Little Endian.” You may get a
warning that the surface is not closed. Save surface anyway.

Exporting Reslicings

We will now reslice and export orthogonal reslicings of our data. Delete all icons in the
Main Panel except for the data icon and an isosurface to serve as a guide for the
transformations that we will be applying.

e Click on the data volume in the Main Panel, and in Properties select the Transform

Editor |$|

¢ In the Manipulator section in the dialog that appears, click on Dialog.
¢ Inthe Transform Editor window that opens, select the Relative Local tab.

¢ In the Rotate section of the tab, enter 90 for degrees, and set the pull-down tab to the
right of degrees to ‘around local x-axis.” Click Apply. The data set will shift to the
new orientation and the modified green data icon will now be indicated by italic font.
Click Close to exit the dialog.

e Right-click on the data icon and then Geometry Transforms—=>Resample
Transformed Image->Create.

e Click on the Resample Transformed Image icon, and in Properties, change the
Mode to extended. In the Preserve option, click VVoxel size. Click Apply.
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Avizo will resample the data and create a new data icon (indicated by ‘.transformed’
suffix appended to its name). Put an Ortho Slice on this icon, and make sure that the
Xy orientation is now in a different plane (horizontal for our croc data)

Click on the .transformed data icon, and then on the main menu File->Save Data As;
in the box that opens, change Save as type to 2D Tiff (*.tif). Change the File name
and make a new destination folder (e.g., hor_reslice). Click Save. You now have a set
of resliced files in the horizontal plane (for this crocodile data set).

To generate a sagittal reslicing click back on the original data icon (still indicated by
italic font). In Properties, select Transform Editor, and Dialog.

In the Transform Editor window click Reset in the Rotation section. This will reset
the data to its original orientation.

Click the Relative Local tab, and then under Rotation, enter 90 for degrees, and
change the pull down menu to the right to ‘around local y-axis,” and click Apply.

Apply a Resample Transformed Image as above, and save the data as 2D Tiff
images.

To add slice numbers to the frames, use ImageJ as discussed above. These exported
frames (with or without slice numbers) can be assembled into a movie. We prefer
QuickTime .mov format because its compression schemes are less ‘lossy’ than other
movie formats. Instructions for generating movies from exported Avizo frames using
QuickTime Pro are presented at the end of this tutorial.

Resampling Data for Equant Voxels

Note that Avizo exports reslicings with the same voxel aspect ratio as in the original data.
If the original voxels are not equant (i.e., have an aspect ratio other than 1:1:1), then the
exported data will retain the same voxel aspect. In such cases, if you wish to have the
exported data with a 1:1:1 aspect ratio, you will need to resample the data to equant
voxels prior to doing the geometry transforms.

To resample to equant voxels, right click on the data icon, and then Compute
->Volume Operations->Resample-> Create.

Click on the Resample icon, and in the Mode section of Properties select voxel size.
In the Voxel Size section, add the new desired resolution. Note that the Input VVoxel
Size is listed above, and can serve as a guide as to how you would like the data
resampled. Keep in mind that resampling to a higher resolution than the input data
involves interpolation. Click Apply.

You can now transform the data as above to generate reslicings.

Measuring: Taking Linear Measurements

Avizo can take Measurements on volumes, isosurfaces, and slices. It is handy to use a
combination of ‘landmarks’ and the ‘measure’ tools to keep track of what is measured.
We will practice taking measurements on an isosurface.
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e Landmarks: These are points of interest in your data volume.

Reload your data (to clear the previously generated transformations).

e To create a landmark, in the main Avizo pull-down menus above the Viewer

window, select Project->Create Object>Points And Lines>Landmarks
- Create; this generates a green Landmarks icon in the Main Panel. Select it,

and then in Properties select the *Landmark Editor’ icon |#—E| .

Edit Mode allows you to add, move, remove, transform, etc., your landmarks.
Adjust the data volume displayed in the Viewer to the appropriate angle and find
a location for a new landmark. Make sure ‘Add’ is selected as the Edit Mode
before attempting to add a landmark.

Using the ‘Arrow’ (Interact) tool, click on the desired location for the landmark.
Repeat this process for each successive landmark. To move a landmark, set the
Edit Mode to ‘“move,’ click the landmark, and then click on the new location. The
landmark will land on the first object it encounters under your mouse click, be it
an isosurface, orthoslice, etc.

The yellow Landmark View icon in the Main Panel allows you to adjust the size
and appearance of the landmarks. The default (i.e., no ‘draw style’ selected) for
the landmarks is to appear as yellow spheres. Accordingly, you may wish to
change the color of the underlying isosurface to a color other than yellow to better
see the landmarks. As of Avizo 8.0, it appears that the only way to change the
color of the landmarks is through the Console command line. The command is
‘<Landmark-ViewName> setColor <Landmarks-Name> <r> <g> <b>.” For
instance, if you have not changed the object names, typing ‘Landmark-View
setColor Landmarks 0 1 0’ to change their color to green.

You can save the landmarks: select the green Landmarks icon in the Main Panel
and in the main Avizo window go to File->Save Data As. Save them as an Ascii
file, and you can open it in a simple text editor like EditPad.

e Measuring Tool: This can be used to measure between landmarks or directly on an

isosurface, volume, or orthoslicee. It is selected in the main Avizo menus under

View->Measuring or by selecting the ‘Measure’ button ‘ on the upper-right
middle margin of the Viewer.

e A new yellow Measurement icon will appear in the Main Panel. Once selected,

you can add various measurements in the Properties window.
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‘3D’ (under Add; or by selecting the ‘3D’ tool from the main Avizo drop-down
menu), maintains the relationship of the lines or other measurements to the object
as you interact with it in the Viewer. If ‘3D’ is not selected,
lines/angles/annotations will remain in their original position regardless of how
you move/rotate/zoom the data volume.

Click Line and using the “‘Arrow’ (Interact) tool, manually draw a line from one
landmark to another, or between any two points. The measurement will show up
in the list in Properties and the length of that line will be given (in mm or
whatever unit used when loading the data). You must re-click Line between each
successive measurement. The line can be made visible or invisible by clicking the

‘eye’ icon #® You can move the locations of the endpoints by selecting the line
in Properties. If you want the line to remain stationary, click on the ‘lock’ icon

1. 1faline is partially obscured because it pierces the volume, you can make it
visible by clicking on the ‘two boxes’ icon L=

Line color, width, and label font size can be changed in Properties (at the bottom
under the list of measurements). Measurements can be deleted by clicking on the
measurement and selecting Delete.

With Angle you can measure angles by selecting the three points that define the
vertex.

With Text you can add annotations in the Viewer. Click the Text button in the
Properties window and then click in the Viewer where the text is to be displayed.
You will only be able to select a spot on an existing object (isosurface, landmark,
etc.) in the Viewer. Change the text as desired in the Properties list by double-
clicking on ‘Annotation.’
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Volume Rendering

Volume rendering, unlike isosurface rendering, assigns an opacity value and a grayscale
(or color) value to every voxel in the dataset. Volume renderings are not hollow like an
isosurface, and if you slice into a volumetric rendering you will see the interior voxels
rendered according to their assigned opacities and color. This type of visualization is
well suited to rendering several materials simultaneously (e.g., fossilized bone vs. matrix
in a fossil, bone vs. flesh in a Recent specimen) by assigning different colors and
opacities to different materials.
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o Delete the Histogram, Landmarks, LandmarkView, and Measurement icons from
the Main Panel. Right-click on the green data icon and select Display->Volume
Rendering->Create. The following icon will appear:

B8 Yolume Rendering Settings [

OB Yolume Rendering [=

A fuzzy rendering of your data, including its surrounding air rendered as semitransparent,
will appear in the Viewer window.

If you click on the lower yellow Volume Rendering icon, the following will appear in
the Properties window:
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e Colormap: allows selection of color map (for the crocodile start with a grayscale
range of 30 to 230 to see the skull).

e Colormap Lookup: choose rgba (alpha will cause data to appear completely white
when rendered; luminance/alpha produces a grayscale rendering).

e Alpha scale: 1 (default; the lower the number, the more transparent the rendering);
this setting auto-renders.

The Colormap editor can be used for more precise specification of colors and opacities
within the displayed volume.

¢ Right-click on Colormap bar, or click Edit (to the right of the Colormap bar), and
select Options—>Edit colormap; this displays a Colormap Editor window including
a histogram that allows you to manipulate the opacity and color of your rendered data.
You can also access the Colormap Editor by selecting the green data icon in the
Main Panel, and then the Window->Colormap pull-down menu above the Viewer
window.
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e The Colormap Editor is divided into 3 main sections: the toolbar (#1 in image
above), color/opacity mapped histogram (#2), and the color gradient bar (#3).

e The toolbar at the top has a colormap selection and options to save and reload the
current colormap. After the Data selection, the buttons from left to right are:

e Adjust Range: Automatically adjust the colormap range to the connected data
range

e Opacity Preset: This menu allows you to replace the whole opacity by one of a
set of predefined curves.
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e Options: Colormap with steps: if this option is chosen, an additional dialog
window pops up, allowing you to subdivide the colormap into a discrete set of
colors.

e Range Editor: Switches to the Range Editor mode.
e Help: Shows help.

e The main part of the Colormap Editor window (#2) displays the data histogram with
the mapped colors and opacities. The horizontal axis (numbers at top) is the data
volume grayscale values and the vertical axis (left) their opacity. The line segment
(indicated by blue arrow in above figure) controls the opacity, with the top of the
window indicating 100% opacity and the bottom 0% opacity (i.e., transparent). You
can move the line using the handles, as well as add and delete handles, by left and
right clicking, respectively, on the line with your mouse. Play with this to see the
effect on the histogram coloring and rendered image. The histogram has a default
white and grey checkered background which is overlaid by the color and opacity
mapped at that data volume value. For example, the highest mapped data value (230
above) has the opacity at 100% and the color as white, so the histogram is colored
white. As the opacity decreases for lower grayscale values, the histogram color (now
blending with tan) becomes more transparent as indicated by the checkered
background.

e The colormap can be edited with the color gradient bar (#3). Click the ‘Edit’ icon

next to it to display the color toolbar if it is not showing. Handles can be
dragged, deleted (by right-clicking mouse on handle), and inserted (left-click on the
bottom of the color gradient bar). For each color handle you can manually set both the
data value to which it is mapped, and its color (by clicking handle and then the ‘Color’
square). The slider on the lower right side of the color gradient bar can be used to
change the blend of colors between two handles.

Note that if you click on the upper yellow Volume Rendering Settings icon, you will
have options for increasing the quality, lighting effects, edge effects, and resolution.

Segmentation

Segmentation involves delineating a subset of the dataset volume that can subsequently
be rendered and measured as a separate object. For example, one might segment the
mandible from the skull allowing it to be rendered as an isolated element, or one might
segment the void space of the cranial cavity to render a digital endocast or to take
volumetric measurements.

Hide the Volume Rendering object that you created in the previous section.

e Right-click the data icon and go to Image Segmentation>Edit new Label
Field=>Create; a green Labels icon will appear directly below the dataset icon in the
Main Panel and Avizo should automatically go straight to the Image Segmentation
view (in a different tab of the Main Panel). If not, click the green Labels icon, and
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then on Image Segmentation in Properties @ . A new window display showing the
3D rendered object along with each slice plane will appear. Select an orientation you
would like to use to start segmenting (you will be able to switch between planes) and
select a view layout (upper right-hand corner of Viewer).
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e You can limit the grayscales displayed by moving the slider in the Zoom and Data
Window. You can scroll through the slices using the keyboard arrow keys or by using
the white slider at the bottom of each 2D view. Use the ‘zoom’ buttons to the left of
this bar to zoom in and out of the viewer windows (current viewer or all, depending on
the selection).

e Select a tool for segmenting from the Tools section. For most of these tools, holding
down the shift key allows you to add to the selection within the current slice, and
holding down the control key allows you to subtract from that selection. Available
tools are:

o ‘E ‘Pick & Move’ allows manipulation of a selection that has been made with
other tools, or with an already-labeled material. It is a handy tool if you wish to
modify a selection or a portion of a selection (e.g., growing or shrinking the
selection, interpolating, etc.).
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4 ‘Brush’ allows quick selection of larger areas (with choice of an appropriate

brush size), but may not be well suited for fine boundaries (e.g., sutures) between
components. Useful options with the brush include *Select only current material’
(if you have multiple components that you are segmenting), and ‘Limited range
only,” which will restrict the brush stroke to a specified range of gray values.

|E| ‘Lasso’ is best for defining segments in which fine lines need to be drawn
(e.g., sutural boundaries). It works like the lasso tool in Photoshop. When the
'‘Auto trace' option is enabled, line segments are automatically fitted to image
edges. For most CT data sets, you will also need to have 'Trace edges' enabled for
the tool to have any chance of finding an edge.

E/ ‘Magic Wand’ is useful for segmenting well-defined components
(grayscales that are discontinuous with the surrounding material, such as the air in
the cranial cavity of a Recent skull). You designate a grayscale range, and when
you click on a pixel (the seed) in the Viewer, Avizo selects all contiguous pixels
whose grayscales fall within that range. The 'all slices' toggle will expand your
selection to 3D. Note that it is generally best to test your selection on one slice
before applying the wand to all slices, as this operation can take a while. If the
'‘Absolute value' option is enabled, then you can specify the exact range of
grayscale values to be selected, which is useful when an absolute threshold is
desirable (e.g., when segmenting features for precise volumetric analysis). If
segmenting multiple materials, the 'same material only' toggle will avoid other
regions that are already segmented. If the 'fill interior' toggle is set, holes inside
the selected region will be filled automatically. Finally, the 'draw limit line' button
allows you to specify additional barriers for 2D region growing. This is especially
useful when extracting endocasts, as it allows you to seal foramina and other
openings.

|£| 'Propagating Contour' is a dynamic contouring tool. Our experience has led
us to avoid this tool. Good luck if you want to give it a go.

|@| ‘Blow’ works like a balloon to fill regions of similar grayscale values. It
operates in a similar way to the magic wand, but gives the user more control on
what qualifies as the edge of the area. Click within the area of interest, and drag to
expand the balloon to fill that space. The higher the ‘Tolerance’ the lower the
tension of the balloon surface and the easier it will be for your balloon to jump
boundaries. Before the computation, the image is smoothed using a Gaussian
smoothing filter. You can change the width of the filter within a range of 1 (no
smoothing) to 8 (very broad smoothing). The default value is 4.
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| “Threshold Tool” allows selection of a particular grayscale threshold range
of values, either for the entire volume, a single slice, or the current material. This
is a great tool for exploring density contrasts in your data.

o |E| |E| “Tophat” and ‘Watershed’ tools. As with the propagating contour
tool, we have found these tools to be of limited utility in segmenting data. Feel
free to have a go of it on your own.

handy for inspecting a feature in different planes.

e After making a selection in several slices using the Tools, there are options for adding,
subtracting, erasing, replacing, or modifying the selection (to either the whole volume
or just the current slice) in the Selection section:

e Clear Selection |ﬂ clears the currently selected region. You can also clear the
selection by typing the letter ‘C.’

-~
e Replace Selected Region |E replaces the material segment with the currently
selected voxels. You can also replace the material by typing the letter ‘R.’

e Add Selected Voxels \@| adds the currently selected voxels to the material
segment. You can also add to the material with the “‘plus’ key.

e Subtract Selected Voxels l@| subtracts the currently selected voxels from the
material segment. You can also subtract from the material with the ‘minus’ key.

e All of these Selection options can operate on either the Current Slice, or the
whole Volume. Note that selecting the Volume mode can be quite slow -
particularly if you are only adding a slice or two.

e The 3D Lasso tools ~J: The two lasso tools can be used
to make a selection on the 3D window (either adding to, or subtracting from a
selection). Clearly these tools are only an option for features extending linearly
through the volume. The other two tools allow you to dilate or erode (expand or
contract, one voxel at a time) a selection (either on one slice or the whole
volume).

o All of these options can operate in either Current Slice or Volume mode.

e You can add new segmented materials by clicking the |£| New Material button
in the Materials section. If you have multiple materials, it is generally good
practice to rename them so that you can keep them straight. Similarly, it is always
a good idea to double-check to make sure that you have selected the appropriate
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material before adding, subtracting, or replacing selections. Oh the horror stories
we could tell!

e Other handy selection features for segmentation (available from the Selection pull-
down menu above the Viewer window);

Grow: performs a dilation of the selection (by one pixel in every direction). Can
be performed on a single slice, all slices in a selected orientation (defined by
active window), or the whole volume.

Shrink: performs an erosion of the selection (by one pixel in every direction).
Can be performed on a single slice, all slices in a selected orientation (defined by
active window), or the whole volume.

Fill: fills in all holes in the current selection. Can be performed on a single slice,
all slices in a selected orientation (defined by active window), or the whole
volume.

Smooth: Will smooth the current selection (either a single slice, or all slices).

Invert: Selects the inverse of the current selection, either for the current slice, or
the whole volume.

Make Ellipse: Replaces the selection in the current slice with the best-fit ellipse
for that selection.

Interpolate: Interpolates the selection between all slices where areas have been
manually selected. Selecting Interpolation again after performing corrections in
certain slices will interpolate the selections between all slices where changes have
been made.

Wrap: Interpolates between selections made in different slice planes.

**SAVE FREQUENTLY** during the segmentation process — it is memory-intensive,
and Avizo likes to crash. File->Save Project As; name the file, then select ‘Auto Save’
in the dialog box that appears.
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Visualizing the Segmented Data

There are several ways to visualize the segmented data, depending on the accuracy of
your selection, the number of segmented regions, and whether you would like it to be
volumetrically rendered.

e If your segmented area(s) closely corresponds to the feature(s) of interest (e.g.,
endocasts selected with the wand tool):

When you have finished segmenting the area of interest, save your project and
select the Project View tab at the top of the Main Panel.

If you have a slow computer, you may wish to resample the data to speed things
up. To do this, right-click on the green Labels icon in the Main Panel and select
Compute->Volume Operations>Resample->Create. In Properties, change
the Average to x: 2 y: 2 z: 2. This will speed up the surface generation
significantly. Hit Apply and a new green labels.Resampled icon will appear in
the Main Panel.

Right-click on the Labels icon (or on your resampled data icon if you created
one) and select Compute->Generate Surface->Create. Click Apply in the
Properties window. This will create a red Generate Surface icon and a green
.surf icon in the Main Panel.

Right-click on the .surf icon and select Display->SurfaceView->Create; a
rendering of your segment(s) will appear in the Viewer. The color of the segment
isosurface corresponds to that used to define the material in the Image
Segmentation view (this can be modified in the Image Segmentation view by
double-clicking the color swatch).

Un-hide any isosurfaces or volume renderings of your data to see your segmented
data surface in the context of the entire data volume.

If you have segmented multiple materials, but only wish to visualize one material,
click on the yellow Surface View icon, and use the drop down menu in the
Materials section to select a material that you wish to hide, and then click
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Remove in the Buffer section. Note that this may cause a loss of ‘shared’
surfaces, so you may need to select the material that you wish to visualize and
Add it to the Buffer to make a surface without holes.

If you wish to volumetrically render your segment, or if you wish to specify an
isosurface threshold within your segment, then you will need to digitally extract
new data volumes based on your segmented materials:Hide all of the currently
viewed objects.

Right-click on the data icon and select Compute->Arithmetic=>Create; a red
Arithmetic icon appears in the Main Panel.

In Properties, under Input A, make sure that your data are selected. In Input B,
use the drop down menu to select your labels.

Set the Result channels to ‘like input A’ and under Expr (expression) enter:
A*(B= =1). Click Apply and wait for a green Result icon to appear in the Main
Panel; this icon represents a new dataset comprising the segmented portion of the
original dataset. In the above expression, A is the entire dataset and we multiplied
this by our segmented material (B) as a mask, resulting in data representing only
that particular segmented material.
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By right-clicking this Result icon you can visualize the data as either an
isosurface or as a volume (see instructions above)
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e To visualize a second segment independently from the first, follow the above
steps, but modify the expression (Expr) in the Arithmetic Properties to “A*(B=
=N)”, where 'N' corresponds to the assigned number of the segmented material in
the Image Segmentation view. The 'Exterior' material corresponds to segment '0'
and the segments that follow are numbered sequentially.

Measuring: Taking Volumetric Measurements

To measure the volume of your segmented materials(s), right-click on the green
Labels icon in the Main Panel and select Measure and Analyze->Material
Statistics> Create. Then click Apply in Properties; a green Material Statistics icon
will appear in the Main Panel.

Click on Show in Properties and a window will pop up with the statistics, including
the volume and statistics related to grayscale values of the segmented region(s). The
Material Statistics object can be saved: File->Save data As, save as a .txt file.

You can also take volumetric measurements and surface area measurements on
extracted isosurfaces. To do this, right click on the extracted isosurface (green icon),
then Measure and Analyze->Surface Area Volume->Create. Click Apply for a
spreadsheet as above.

Making Cutaway Animations

We will now make animation frames for a couple of movies using volume rendering.
Delete everything from the Main Panel except for your dataset and VVolume Rendering
icons.

In the Main Panel, right-click the green data icon, and select Display->Clipping
Plane->Create; this will create an orange Clipping Plane icon in the Main Panel.

Select the Clipping Plane icon and, for a coronal cutaway of the Crocodylus dataset,
click the xy button under Orientation in its Properties window. Click on the “Clip’

button EB in Properties. Pressing this button once clips the volume in one direction,
pressing it a second time “unclips,” and pressing it a third time clips the volume in the
opposite direction (the one we will use for our transverse cutaway). You can use the
‘Arrow’ (Interact) tool in the Viewer, or the Translate slider in Properties, to scroll
through the volume.

If you need to rotate the clipping plane (e.g., if the scan is not orthogonal), check the
‘rotate’ box under Options and a rotation sphere will appear in the Viewer. Use this to
adjust the orientation of the plane. Be sure to un-click ‘rotate’ when you are done or
the sphere will be rendered as part of the animation.

When the clipping plane has been adjusted to the desired orientation, adjust the view
of the specimen as desired for the animation.



Turn off the frame of the clipping plane by unchecking the Frame 'show' box in
Properties. Move the Translate slider in Properties to zero so that the entire
specimen is visible.

Once the volume rendering and clipping plane are adjusted in the Viewer, right-click
on the orange Clipping Plane icon in the Main Panel and Animate->Animate
Ports—>Create.

For a transverse (coronal) cutaway, leave Time at 0 and type in the formula ‘0+t*1’ in
the Translate box in Properties.

Right-click the yellow Animate Ports icon and select Compute->Movie Maker
- Create. First select ‘“TIFF images’ as the File Format and then under Filename
browse to the destination folder (create a new folder called “coronal_cutaway”) for the
files. Enter the number of Frames you would like (e.g., 174 or approximately every
fifth slice on the crocodile data), then click Apply.

For a frontal (horizontal) cutaway, proceed in the same manner as the transverse
(coronal) cutaway. The sagittal cutaway differs because Avizo places the origin of the
sagittal axis at the right cheek rather than the left (our standard). Accordingly, for a

sagittal animation, click fj only once, put the Translate slider at *100’, set Time to
0 and type in the formula "100-t*1" in the Translate box in Properties.

Making Rotation Animations

For rotations around different axes, a preset exists and can be used as follows:

e Right-click on the green data icon and select Animate->Rotate->Create; a blue

ObjectRotate icon appears in the Main Panel; click on it.

¢ In the Viewer, orient the volume as you would like it to start the animation using
the planar icons.

e In Rotate Properties, under Center click Use bbox center; this will place the
center of rotation at the center of the volume.

e The axes of rotation can be designated by entering a ‘1’ in the first (x axis),
second (y axis), or third (z axis) box under Axis. Entering ‘1’ in more than one
box produces a diagonal rotation around those axes. Entering a *-1” will reverse
the direction of rotation. You can see how the volume will rotate by moving the
Time slider back and forth.

¢ Rotation degrees can be changed if you do not want a full 360 degree rotation.

¢ Right-click on the Rotate icon and select Compute->Movie Maker->Create; a red

Movie Maker icon appears in the Main Panel; click on it.

e In Properties first select “TIFF images’ as the File Format and then under
Filename browse to the destination folder (create a new folder) for the files.
Specify the desired number of Frames (our standard is 90, but because the first
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and last frame of a spin movie will be the same, enter 91). Click Apply and the
movie will generate.

If a volume was scanned non-orthogonally and you would like to rotate it to orthogonal
and maintain that orientation for the animations you can use the Camera-Orbit function.
This is also a quick way to rotate the volume about an arbitrary axis.

Use the manual and virtual Trackballs in the Viewer to position the rendered volume
as desired.

Right-click in the Main Panel, and Create Object=>Animations and Scripts>
Camera Orbit->Create. Click on the green Camera-Orbit icon that appears in the
Main Panel.

In Properties, under Action select ‘up direction’ and click recompute. The camera
has now been re-oriented relative to the volume. Use the Time slider to scroll through
the new rotation direction.

Right-click on the Camera-Orbit icon and select Compute=>Movie
Maker->Create. Enter desired parameters in Properties, and Apply.

Type ‘viewer rotate (+ or -) 90 (X, y or z)’ in the Console to rotate the volume in 90
degree increments from its ‘new orthogonal® orientation, and repeat these steps for
animations around other axes.



32

QUICKTIME

We prefer to make movies in QuickTime because its compression is far superior for
slices than that used in the .AVI format. The downside is that it is tricky to embed the
animations in PowerPoint presentations. You would need to buy QuickTime Pro ($29.99
as of February 2015) to make movies or to export frames from existing movies — the free
QuickTime viewer does not offer these functions.

Launch QuickTime.

e File=>Open Image Sequence; navigate to a folder containing the images you would
like to assemble into a movie and click on the first one. Frame Rate controls how fast
the movie plays; we generally use 12 or 15 frames per second. Click Open and a
QuickTime movie will appear.

e File->Export; navigate to where you would like to save the movie and name it.
Under Export select “‘Movie to QuickTime Move’ and then hit Options.

e In the Movie Settings window that appears, hit Settings. Compression Type should
be “‘JPEG 2000’ (we have found this compression to do the best job of making the file
size small while maintaining image quality); Frame Rate must be set to the same
frame rate at which you imported the frames (“‘Current’), otherwise the movie will not
play smoothly (or at all); Depth is grayscale or color; Quality should be medium to
high for movies where file size is not a concern, and low to medium for animations to
be served via the Web; hit OK. Then hit OK again, and then Save to generate the
movie.

You can also export one or all frames from a QuickTime movie. To do this, open the
movie and select File->Export. Under Export select ‘Movie to Image Sequence,” or
‘Movie to BMP,” etc. Then hit Options, select the preferred file Format and
compression scheme (available via the Options button once Format has been
selected); hit OK, then Save to export the frames.
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